PSM-599263 - Visa Processing and File Delay

Incident Report for weareplanet

Resolved

Following recovery from the external Visa incident affecting Visa Clearing Exchange (VCX) processing, the affected Visa transactions have been reprocessed. Any affected reporting or downstream files will be processed and included in subsequent file runs as soon as possible.
Posted Jul 27, 2026 - 16:18 UTC

Monitoring

Following resolution of the previously reported Visa VSS file delay, Visa has reported a separate incident affecting Visa Clearing Exchange (VCX) processing.

As a result of the Visa incident, a subset of Visa transactions require reprocessing and may experience delays in associated downstream processing and file delivery.

Recovery activities are currently underway using remediation guidance provided by Visa. Any affected transactions will be processed and included in subsequent file runs where applicable.
Posted Jul 26, 2026 - 16:36 UTC
This incident affected: Planet Reporting Portal (MAS Portal - PWEB FIFP - Daily Planet Files, MAS Portal - PWEB FIFP - Report Files).