PSM‑543618 | Mastercard Payment Disruption via Elavon

Incident Report for weareplanet

Resolved

The issue affecting Mastercard payments via third‑party acquirer Elavon has been resolved. Transaction processing is operating as expected, and we will continue to monitor.
Posted Apr 21, 2026 - 09:46 UTC

Identified

The issue has been identified, and a fix is currently being implemented. We will continue to monitor the service and provide further updates as needed.
Posted Apr 21, 2026 - 09:12 UTC

Update

The issue continues to be investigated in collaboration with the third‑party acquirer.
Posted Apr 21, 2026 - 08:34 UTC

Update

The issue continues to be investigated in collaboration with the third‑party acquirer. We will provide further updates as more information becomes available.
Posted Apr 21, 2026 - 07:59 UTC

Update

The disruption affecting Mastercard payments via third‑party acquirer Elavon is still ongoing. We continue to investigate and will provide further updates as they become available.
Posted Apr 21, 2026 - 07:36 UTC

Investigating

Mastercard payments processed via third‑party acquirer Elavon are currently experiencing disruption. We are monitoring the situation and will provide updates as available.
Posted Apr 21, 2026 - 07:13 UTC
This incident affected: Third-Party Services (Third-Party Acquirers / Payment Processors).