PSM-610023 | Payment Terminal Disruption

Incident Report for weareplanet

Resolved

This incident has been resolved.
Posted Aug 14, 2026 - 07:38 UTC

Update

Our monitoring has observed a return to normal service for payment terminals at the affected customer locations. Services are operating as expected, and monitoring will continue.
Posted Aug 14, 2026 - 07:37 UTC

Identified

Our teams are still investigating and working to restore service for the affected payment terminals.
Posted Aug 14, 2026 - 07:27 UTC

Investigating

We are currently investigating an issue affecting payment terminals at a subset of customer locations. Our teams are actively investigating and working to restore normal service.
Posted Aug 14, 2026 - 07:06 UTC
This incident affected: Planet Gateway - Card Present (Cluster 000080, Cluster 000086, Cluster 000089).