PSM-578803 | Service Disruption

Incident Report for weareplanet

Resolved

Services have returned to normal operation and are operating as expected. Monitoring will continue to ensure ongoing stability.
Posted Jun 18, 2026 - 10:51 UTC

Monitoring

An issue is impacting some services across the Planet platform. Our teams are actively investigating and working towards a resolution.
Posted Jun 18, 2026 - 10:20 UTC
This incident affected: Datatrans (Datatrans Payment Gateway) and Planet Tax-Free Refund Services/Solutions (Refund Kiosks).