Transactions are now processing as expected for the affected customers. Mastercard has confirmed the issue was related to a global Mastercard outage, which has since been resolved. Our teams will continue to monitor for stability.
Posted Aug 15, 2026 - 05:57 UTC
Update
Transactions are now processing successfully again for the affected customers. Mastercard has confirmed the issue was related to a global Mastercard outage. Monitoring will continue to ensure stability.
Posted Aug 15, 2026 - 05:48 UTC
Update
Our teams are continuing to troubleshoot the issue. At this stage, the increased rejections appear to be limited to Mastercard transactions for a subset of customers. Further updates will follow.
Posted Aug 15, 2026 - 05:26 UTC
Update
Our teams are continuing to investigate the increased transaction rejection rate affecting a subset of customers. Further updates will be provided as more information becomes available.
Posted Aug 15, 2026 - 05:11 UTC
Investigating
We are currently investigating an increased transaction rejection rate affecting a subset of customers. Our teams are actively investigating.