Next Steps: We will provide a full RCA report for this issue, available in 5 working days.
We apologize again for any inconvenience caused.
King Regards, Your Planet Team
Posted Jul 05, 2025 - 13:31 UTC
Update
Dear Valued Customer,
We’re sorry to let you know that the issue we raised in our previous email is still ongoing, majority of services have been restored and we are still working hard on restoring all remaining services.
We are taking steps to analyze the impact and restore full service as quickly as possible.
A further update will follow in the next 30 minutes.
Kind Regards, Your Planet Team
Posted Jul 05, 2025 - 13:00 UTC
Update
Dear Valued Customer,
We’re sorry to let you know that the issue we raised in our previous email is still ongoing, majority of services have been restored and we are still working hard on restoring all remaining services.
We are taking steps to analyze the impact and restore full service as quickly as possible.
A further update will follow in the next 30 minutes.
Kind Regards, Your Planet Team
Posted Jul 05, 2025 - 12:28 UTC
Update
Dear Valued Customer,
We’re sorry to let you know that the issue we raised in our previous email is still ongoing, majority of services have been restored and we are still working hard on restoring all remaining services.
We are taking steps to analyze the impact and restore full service as quickly as possible.
A further update will follow in the next 30 minutes.
Kind Regards, Your Planet Team
Posted Jul 05, 2025 - 11:31 UTC
Update
Dear Valued Customer,
We’re sorry to let you know that the issue we raised in our previous email is still ongoing, majority of services have been restored and we are still working hard on restoring all remaining services.
We are taking steps to analyze the impact and restore full service as quickly as possible.
A further update will follow in the next 30 minutes.
Kind Regards, Your Planet Team
Posted Jul 05, 2025 - 11:00 UTC
Update
Dear Valued Customer,
We’re sorry to let you know that the issue we raised in our previous email is still ongoing, some services have been restored and we are still working hard on restoring all remaining services.
We are taking steps to analyze the impact and restore full service as quickly as possible.
A further update will follow in the next 30 minutes.
Kind Regards, Your Planet Team
Posted Jul 05, 2025 - 10:30 UTC
Update
Dear Valued Customer,
We’re sorry to let you know that the issue we raised in our previous email is still ongoing, some services have been restored and we are still working hard on restoring all remaining services.
We are taking steps to analyze the impact and restore full service as quickly as possible.
A further update will follow in the next 30 minutes.
Kind Regards, Your Planet Team
Posted Jul 05, 2025 - 10:09 UTC
Update
Dear Valued Customer,
We’re sorry to let you know that the issue we raised in our previous email is still ongoing, some services have been restored and we are still working hard on restoring all remaining services.
We are taking steps to analyze the impact and restore full service as quickly as possible.
A further update will follow in the next 30 minutes.
Kind Regards, Your Planet Team
Posted Jul 05, 2025 - 09:32 UTC
Update
Dear Valued Customer,
We’re sorry to let you know that the issue we raised in our previous email is still ongoing, some services have been restored and we are still working hard on restoring all remaining services.
We are taking steps to analyze the impact and restore full service as quickly as possible.
A further update will follow in the next 30 minutes.
Kind Regards, Your Planet Team
Posted Jul 05, 2025 - 08:55 UTC
Monitoring
Dear Valued Customer,
We’re sorry to let you know that the issue we raised in our previous email is still ongoing, some services have been restored and we are still working hard on restoring all remaining services.