Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Sep 24, 2026 - 11:00 UTC
Scheduled
Region: Global
Maintenance Reference: PSM-613566
Maintenance Start: Thursday, 24 September 2026 | 11:00 UTC Maintenance End: Thursday, 24 September 2026 | 12:30 UTC
Maintenance Type: Emergency MAS Application Maintenance (short-notice change)
Systems Impacted: MAS MWEB/PWEB System
Downtime and Impact: There is no expected downtime or customer impact while this maintenance is carried out.
Rollback Plan: In the unlikely event that any issues are encountered during the maintenance process that cannot be resolved, rollback procedures are in place to restore the previous application version and ensure continued platform stability.
Posted Sep 24, 2026 - 10:13 UTC
This scheduled maintenance affected: Planet Reporting Portal (Merchant Accounting System - MAS Portal - MWEB, Merchant Accounting System - MAS Portal - PWEB FIFP).