PSM-548750 | Funding Delays (Canada Locations)

Incident Report for weareplanet

Update

Payment files for the impacted dates have now been delivered and processed, with the exception of payments dated 24 April, which remain outstanding. Teams continue to work on this as a priority in collaboration with the acquiring partner.
Posted Apr 30, 2026 - 13:22 UTC

Identified

Some merchants may be experiencing funding delays due to an issue affecting the delivery of payment files to a specific acquiring partner. This is impacting a subset of customers only.
Our teams are actively investigating and working in collaboration with the acquirer to address this matter.
Posted Apr 28, 2026 - 12:00 UTC
This incident affects: Planet Acquiring Services / Host System (Indirect Funding).