PSM-622349 | Non-Planet Acquiring Transaction Disruption | First Abu Dhabi Bank

Incident Report for weareplanet

Resolved

Our monitoring has observed a return to normal service. Our teams will continue to monitor for stability.
Posted Sep 07, 2026 - 10:07 UTC

Investigating

We are currently investigating an issue affecting transactions acquired via the third-party acquirer First Abu Dhabi Bank. Our teams are actively investigating.
Posted Sep 07, 2026 - 09:51 UTC
This incident affected: Planet Gateway - Card Present (Cluster 000067).