PSM-544471 | Planet Tax-Free | CIVA - Voucher issuing Disruptions in Portugal

Incident Report for weareplanet

Resolved

The issue affecting voucher issuing via CIVA for Planet Tax‑Free services in Portugal has been resolved. Services are operating as expected, and we will continue to monitor.
Posted Apr 22, 2026 - 01:00 UTC

Investigating

Some customers may be experiencing disruptions with voucher issuing via CIVA for Planet Tax‑Free services in Portugal. Our teams are investigating the issue.
Posted Apr 21, 2026 - 19:30 UTC
This incident affected: Planet Tax-Free Refund Services/Solutions (Portugal - CIVA).