PSM‑564156 | Delays in Planet Funding Processing

Incident Report for weareplanet

Monitoring

The issue has been mitigated and services are operating normally.
We are continuing to monitor and validate processing, with some customers potentially experiencing residual delays.
Posted May 25, 2026 - 11:24 UTC

Update

Initial remediation actions have been implemented following identification of the issue.
Some customers may continue to experience delays while we validate service stability and complete outstanding processing.
Posted May 25, 2026 - 09:51 UTC

Identified

We have identified the underlying issue and are working on a fix.
Some customers are currently experiencing delays, and our teams are actively working to restore normal processing as quickly as possible.
Posted May 25, 2026 - 08:36 UTC

Update

At this stage, impact remains under assessment while our teams work to identify the underlying cause.
Posted May 25, 2026 - 06:49 UTC

Investigating

We have identified processing disruptions for Planet Funding Services which may lead to delays in funding.
Our teams are actively working to identify the cause and restore normal service as quickly as possible.
Posted May 25, 2026 - 06:22 UTC
This incident affects: Planet Acquiring Services / Host System (Direct Funding, Indirect Funding).