Incident Alert | PSM-302701 | Planet Switch – Intermittent Visa Transaction Disruptions

Incident Report for weareplanet

Resolved

Dear Valued Customer,

We wish to inform you that the transactions have continued to be successful.

This incident is now resolved, and the service will be monitored closely.

The transaction disruptions were intermittent between the below time windows.

Incident Start: 19/04/2025 | 12:35 CEST
Incident End: 19/04/2025 | 15:03 CEST

Affected Service: Planet Switch – Intermittent Visa Transaction Disruptions

Next Steps:
We will provide a full RCA report for this issue, available in 5 working days.

We apologize again for any inconvenience caused.

King Regards,
Your Planet Team
Posted Apr 19, 2025 - 17:27 UTC

Update

Dear Valued Customer,

We’re still monitoring the system closely. Currently transactions are continuing to flow successfully as normal but due to the intermittent nature of this incident we will continue to keep you updated.

Incident Start: 19/04/2025 | 14:30 CEST

Affected Service: Planet Switch – Intermittent Visa Transaction Disruptions

A further update will follow in the next 60 minutes or sooner.

Our teams are still working hard to resolve the incident at the earliest possible opportunity.

Please bear with us while we work on resolving the incident.

We apologize for any inconvenience caused.

Kind Regards,
Your Planet Team
Posted Apr 19, 2025 - 16:43 UTC

Monitoring

Dear Valued Customer,

We’re still monitoring the system closely. Currently transactions are continuing to flow successfully as normal but due to the intermittent nature of this incident we will continue to keep you updated.

Incident Start: 19/04/2025 | 14:30 CEST

Affected Service: Planet Switch – Intermittent Visa Transaction Disruptions

A further update will follow in the next 60 minutes or sooner.

Our teams are still working hard to resolve the incident at the earliest possible opportunity.

Please bear with us while we work on resolving the incident.

We apologize for any inconvenience caused.

Kind Regards,
Your Planet Team
Posted Apr 19, 2025 - 15:45 UTC

Update

Dear Valued Customer,

We’re still monitoring the system closely. Currently transactions are generally flowing successfully but a very small amount disruptions were observed in the last 30 minutes. Due to the intermittent nature of this incident, we will continue to keep you updated.

Incident Start: 19/04/2025 | 14:30 CEST

Affected Service: Planet Switch – Intermittent Visa Transaction Disruptions

A further update will follow in the next 30 minutes.

Our teams are still working hard to resolve the incident at the earliest possible opportunity.

Please bear with us while we work on resolving the incident.

We apologize for any inconvenience caused.

Kind Regards,
Your Planet Team
Posted Apr 19, 2025 - 15:17 UTC

Update

Dear Valued Customer,

We’re still monitoring the system closely. Currently transactions are continuing to flow successfully as normal but due to the intermittent nature of this incident we will continue to keep you updated.

Incident Start: 19/04/2025 | 14:30 CEST

Affected Service: Planet Switch – Intermittent Visa Transaction Disruptions

A further update will follow in the next 30 minutes.

Our teams are still working hard to resolve the incident at the earliest possible opportunity.

Please bear with us while we work on resolving the incident.

We apologize for any inconvenience caused.

Kind Regards,
Your Planet Team
Posted Apr 19, 2025 - 14:48 UTC

Update

Dear Valued Customer,

We’re still monitoring the system closely. Currently transactions are continuing to flow successfully as normal but due to the intermittent nature of this incident we will continue to keep you updated.

Incident Start: 19/04/2025 | 14:30 CEST

Affected Service: Planet Switch – Intermittent Visa Transaction Disruptions

A further update will follow in the next 30 minutes.

Our teams are still working hard to resolve the incident at the earliest possible opportunity.

Please bear with us while we work on resolving the incident.

We apologize for any inconvenience caused.

Kind Regards,
Your Planet Team
Posted Apr 19, 2025 - 14:21 UTC

Update

Dear Valued Customer,

We’re still monitoring the system closely. Currently transactions are flowing successfully as normal but due to the intermittent nature of this incident we will continue to keep you updated.

Incident Start: 19/04/2025 | 14:30 CEST

Affected Service: Planet Switch – Intermittent Visa Transaction Disruptions

A further update will follow in the next 30 minutes.

Our teams are still working hard to resolve the incident at the earliest possible opportunity.

Please bear with us while we work on resolving the incident.

We apologize for any inconvenience caused.

Kind Regards,
Your Planet Team
Posted Apr 19, 2025 - 13:58 UTC

Update

Dear Valued Customer,

We’re currently monitoring the system closely. Currently we do not see any transaction disruptions but due to the intermittent nature of this incident we will continue to keep you updated.

Incident Start: 19/04/2025 | 14:30 CEST

Affected Service: Planet Switch – Intermittent Visa Transaction Disruptions

A further update will follow in the next 30 minutes.

Our teams are still working hard to resolve the incident at the earliest possible opportunity.

Please bear with us while we work on resolving the incident.

We apologize for any inconvenience caused.

Kind Regards,
Your Planet Team
Posted Apr 19, 2025 - 13:39 UTC

Investigating

Dear Valued Customer,

We are sorry to inform you that our monitoring systems have detected some further intermittent anomalies in system performance with Planet Switch – Visa Transaction transactions.

Incident Start: 19/04/2025 | 14:30 CEST

Affected Service: Planet Switch – Intermittent Visa Transaction Disruptions

We are taking steps to analyze the impact and restore full service as quickly as possible.

A further update will follow in the next 30 minutes.

Kind Regards,
Your Planet Team
Posted Apr 19, 2025 - 13:08 UTC
This incident affected: Planet Authorization System - Switch Services (PSW) (Planet Switch - All regions).