PSM-599263 - Visa Processing and File Delay

Incident Report for weareplanet

Resolved

Visa has advised that the issue has been mitigated on their side. Any affected transactions will be processed or included in the next scheduled file runs as the data becomes available.
Posted Jul 25, 2026 - 17:48 UTC

Monitoring

We are aware of an external Visa incident causing delayed delivery of VSS settlement reports. As a result, Visa transaction processing is delayed and affected transactions may be missing from the associated core daily Planet files (PIF, ACH, ATM etc). Any delayed transactions will be included in the next scheduled files once the data is received.
Posted Jul 25, 2026 - 17:23 UTC
This incident affected: Planet Reporting Portal (MAS Portal - PWEB FIFP - Daily Planet Files).