PSM-576027 | Incorrect transaction rates for Bank of China

Incident Report for weareplanet

Resolved

The issue affecting FX rates on some transactions has been mitigated.

Normal service has been restored and we will continue to monitor. We apologise for any inconvenience caused.
Posted Jun 14, 2026 - 13:32 UTC

Investigating

We are currently investigating an issue affecting a subset of transactions where abnormal FX rates have been observed.

Our internal teams are actively investigating the issue with priority and working to identify the root cause.
Posted Jun 14, 2026 - 12:47 UTC
This incident affected: Planet Acquiring Services / Host System (Planet Acquiring Host - Hong Kong, Planet Acquiring Host - Asia Pacific).