We are continuing to work through recovery activities to restore normal service. Some customers may still experience intermittent errors or delays during this period.
Our teams are actively implementing corrective actions and will provide further updates as progress continues.
Posted May 23, 2026 - 19:38 UTC
Update
We are continuing to restore services and have progressed to the next stage of recovery. Some operations may remain delayed while remediation activities are completed.
Our teams remain actively engaged, and we will provide further updates as progress continues.
Posted May 23, 2026 - 18:37 UTC
Identified
Recovery efforts are ongoing, with actions underway to stabilise the platform and restore full service. We are seeing progress and continue to monitor closely; further updates will be shared as recovery advances.
Posted May 23, 2026 - 17:17 UTC
Update
Services remain impacted across Planet Tax‑Free, with login and issuing functionality affected. Our teams continue to investigate and are actively working towards stabilisation.
Further updates will be provided as progress is made.
Posted May 23, 2026 - 16:17 UTC
Update
Disruptions are currently affecting Planet Tax‑Free services, including user login and voucher issuing functionality. Our teams are investigating the issue.