PSM-585990 | 4G Terminals

Incident Report for weareplanet

Resolved

Our connectivity partner has confirmed the outage has been resolved and 4G Terminal connectivity is operating as expected.
If you continue to experience issues, please restart your terminal. If problems persist, please contact our support team.
Posted Jul 01, 2026 - 12:16 UTC

Monitoring

Our connectivity partner has advised that service is starting to recover. Affected terminals are expected to reconnect automatically.
Posted Jul 01, 2026 - 11:41 UTC

Investigating

We are currently investigating an issue impacting 4G Terminal connectivity. Our teams are working to identify the cause.
Posted Jul 01, 2026 - 10:57 UTC
This incident affected: Planet Gateway - Card Present (Planet Card Present Gateway - EMEA).