PSM-552170 | Late presentment of transactions

Incident Report for weareplanet

Update

We are continuing to investigate this issue.
Posted May 05, 2026 - 14:07 UTC

Investigating

Due to an incident, a subset of customers may experience delays to expected funding and settlement today as a result of late presentment of transactions. Our teams are investigating.
Posted May 05, 2026 - 14:07 UTC
This incident affects: Planet Acquiring Services / Host System (Direct Funding, Indirect Funding).