Incident Alert | PSM-299016 | Planet Switch – Transaction Disruptions

Incident Report for weareplanet

Resolved

Dear Valued Customer,

We are happy to inform you that our teams have restored the service.
We will continue to monitor the system following the incident.

Impact:

Next Steps:
We will provide a full RCA report for this issue, available in 5 working days.

We apologize again for any inconvenience caused.

Your Planet Team

If you encounter any urgent issues, please contact Customer Support by telephone using your country number available at www.weareplanet.com/support.

For less critical issues or queries, please raise a ticket via email by sending a brief description of your issue along with any supporting information to support@weareplanet.com.
Posted Apr 12, 2025 - 14:54 UTC

Investigating

Dear Valued Customer,

We are sorry to inform you that our monitoring systems have detected a possible degradation.

We are working on analysing the impact and restoring the service to you as quickly as possible.

A further update will follow in the next 30 minutes.

Kind Regards,
Your Planet Team
Posted Apr 12, 2025 - 14:41 UTC
This incident affected: Planet Authorization System - Switch Services (PSW) (Planet Switch - All regions).