Third-Party Acquirer Disruption | PSM-516459 | Elavon US

Incident Report for weareplanet

Resolved

The issue affecting the third‑party acquirer has been resolved. Related services are operating as expected, and monitoring continues.
Posted Mar 09, 2026 - 21:09 UTC

Identified

A third‑party acquirer is currently experiencing an outage, which may impact transaction processing for some customers. We are monitoring the situation closely.
Posted Mar 09, 2026 - 15:26 UTC
This incident affected: Third-Party Services (Third-Party Acquirers / Payment Processors).