This issue has been resolved and card payments through Protel are processing normally. We apologise for any inconvenience caused.
Posted Jul 18, 2026 - 10:12 UTC
Identified
We have identified the cause of the issue affecting card payments processed through Protel, and are working to restore normal service as quickly as possible. Impact is currently limited to European customers; we are monitoring other regions.
Posted Jul 18, 2026 - 09:31 UTC
Investigating
We are currently investigating an issue affecting card payments processed through Protel for European customers. Alternative standalone payment processing remains available. Our teams are working to identify the cause and restore normal service as quickly as possible.
Posted Jul 18, 2026 - 09:07 UTC
This incident affected: PMS - Protel Cloud Solutions | Europe, North America (Protel IDS Interface, PCI-DSS Environment).