Incident Alert | PSM-344714 | Planet Gateway – Transaction Disruptions

Incident Report for weareplanet

Resolved

This incident has been resolved.
Posted Jun 20, 2025 - 10:22 UTC

Update

Dear Valued Customer,

This incident has been resolved, and we are now monitoring the services.

Incident Start: 20/06/2025 | 10:09 CEST~
Incident End: 20/06/2025 | 11:02 CEST~

Affected Service: Planet Gateways – Transaction Disruptions

Impact: Various Planet Services were impacted due to a network level disruption.

Next Steps:
We will provide a full RCA report for this issue, available in 5 working days.

We apologize again for any inconvenience caused.

Kind Regards,
Your Planet Team
Posted Jun 20, 2025 - 10:22 UTC

Update

Dear Valued Customer,

We are sorry to inform you that our monitoring systems have detected anomalies in system performance.

Incident Start: 20/06/2025 | 10:15 CEST

Affected Service: Planet Gateway – Transaction Disruptions

We are taking steps to analyze the impact and restore full service as quickly as possible.

A further update will follow in the next 60 minutes or sooner.

Kind Regards,
Your Planet Team
Posted Jun 20, 2025 - 09:30 UTC

Update

We are continuing to investigate this issue.
Posted Jun 20, 2025 - 09:03 UTC

Update

We are continuing to investigate this issue.
Posted Jun 20, 2025 - 08:58 UTC

Investigating

Dear Valued Customer,

We are sorry to inform you that our monitoring systems have detected anomalies in system performance.

Incident Start: 20/06/2025 | 10:15 CEST

Affected Service: Planet Gateway – Transaction Disruptions

We are taking steps to analyze the impact and restore full service as quickly as possible.

A further update will follow in the next 60 minutes or sooner.

Kind Regards,
Your Planet Team
Posted Jun 20, 2025 - 08:31 UTC
This incident affected: Planet Tax Free Solutions (Planet Tax Free - Europe, Planet Tax Free – Middle East) and Planet Card Present Gateway (Planet Card Present Gateway).