Service has returned to normal operation. Our teams will continue investigations in collaboration with applicable third‑party providers.
Posted Jun 03, 2026 - 14:15 UTC
Update
Troubleshooting is continuing, and service conditions remain largely unchanged. We continue to observe an increased rejection rate, with rejections originating from the third‑party acquirer.
Posted Jun 03, 2026 - 13:20 UTC
Update
Our teams are continuing to investigate the issue in collaboration with our vendors.
Posted Jun 03, 2026 - 12:25 UTC
Update
Investigation is ongoing and our teams continue to look into the issue.
Posted Jun 03, 2026 - 11:42 UTC
Update
We are continuing to investigate this issue.
Posted Jun 03, 2026 - 11:27 UTC
Update
Our teams are continuing to investigate the issue.
Posted Jun 03, 2026 - 11:26 UTC
Update
Our teams are continuing to investigate the issue. Current indications show the increased rejections are impacting VISA transactions.
Posted Jun 03, 2026 - 11:19 UTC
Investigating
A subset of customers may be experiencing transaction disruptions on the Planet Card‑Present Gateway. Impacted customers will have received a notification via the Status Page; if you have not received an email, your services are not affected.
Posted Jun 03, 2026 - 11:03 UTC
This incident affected: Planet eCommerce Gateway - Digital / Web Payments (Payment Gateway Web2Pay WB) and Planet Gateway - Card Present (Cluster 000084, Cluster 000086).