PSM-554923 | Planet Card-Present Gateway | UAE Locations

Incident Report for weareplanet

Resolved

Service in this location is operating as expected. A small number of customer‑specific cases are being handled through standard support channels.
Posted May 08, 2026 - 12:19 UTC

Investigating

Some locations in the UAE may be experiencing intermittent issues processing payments. Our teams are investigating and working to restore normal service as quickly as possible.
Posted May 08, 2026 - 11:58 UTC
This incident affected: Planet Gateway - Card Present (Cluster 000067).