PSM-567600 | Protel Cloud PMS Service Disruptions

Incident Report for weareplanet

Monitoring

Services have returned and are operating as expected. Our teams are continuing to monitor.
Posted May 29, 2026 - 16:44 UTC

Update

We are continuing to investigate this issue.
Posted May 29, 2026 - 16:32 UTC

Investigating

Access to certain protel services is currently interrupted for some customers. We are working to resolve this issue as soon as possible.
Posted May 29, 2026 - 16:25 UTC
This incident affects: PMS - Protel Cloud Solutions | Europe, North America (Protel Cloud PMS), PMS - Protel Cloud Solutions | Australia, Asia (Protel Cloud PMS), and PMS - Protel Cloud Solutions | Africa (Protel Cloud PMS).