Services are operating normally following earlier disruption to transaction processing. All identified issues have been addressed and systems are stable.
We will continue to review this event as part of our post-incident process.
Posted May 24, 2026 - 18:49 UTC
Update
Services are operating normally, and no further customer impact is being observed. We continue to monitor while final recovery activities are completed.
Posted May 24, 2026 - 18:19 UTC
Update
Services are currently stable following earlier disruption to transaction processing.
A limited number of transactions were impacted, and corrective actions have been completed. We continue to monitor performance while final recovery activities are carried out to ensure full normal operation.
Further updates will be provided as needed.
Posted May 24, 2026 - 17:52 UTC
Monitoring
Services are currently stable, although some customers may experience minor intermittent transaction processing issues or delays. Our teams are continuing recovery actions to restore full normal operation
Posted May 24, 2026 - 17:16 UTC
Update
We are continuing to investigate an earlier disruption impacting transaction processing.
Services are currently stable, although some customers may experience minor intermittent transaction processing issues or delays. Our teams are completing recovery actions to restore normal operation.
Further updates will be provided as more information becomes available.
Posted May 24, 2026 - 16:57 UTC
Investigating
We are investigating an issue impacting PSW systems, which may result in intermittent transaction failures and service instability.
Our teams have stabilised services by failing over to secondary capacity and are continuing to monitor performance while investigating the underlying cause. Further updates will be shared as more information becomes available.