External to Planet | Third-Party Acquirer | PSM-562664 | Nets

Incident Report for weareplanet

Resolved

Nets has confirmed resolution of the card transaction issue as of 14:45 CEST, and services are operating as expected.
Posted May 21, 2026 - 14:07 UTC

Investigating

We have been informed of an incident affecting payments via third‑party acquirer Nets. Further information is available on the Nets status page: https://www.nets.eu/Pages/operational-status.aspx
Posted May 21, 2026 - 08:22 UTC
This incident affected: Third-Party Services (Third-Party Acquirers / Payment Processors).