Incident Alert | PSM-344836 | Planet Services Disruptions

Incident Report for weareplanet

Resolved

Dear Valued Customer,

We wish to inform you that our teams have restored the service.

We will continue to monitor the system following the incident.

Incident Start: 23/06/2025 | 13:07 CEST.
Incident Start: 23/06/2025 | 13:22 CEST.

Affected Service: Planet Tax Free – Service Disruptions

We apologize again for any inconvenience caused.

King Regards,
Your Planet Team
Posted Jun 23, 2025 - 11:37 UTC

Investigating

Dear Valued Customer,

We are sorry to inform you that our monitoring systems have detected anomalies in system performance.

Incident Start: 23/06/2025 | 13:09 CEST.

Affected Service: Planet Gateways, Planet Tax Free

We are taking steps to analyze the impact and restore full service as quickly as possible.

A further update will follow in the next 30 minutes.

Kind Regards,
Your Planet Team
Posted Jun 23, 2025 - 11:19 UTC
This incident affected: Planet Tax Free Solutions (Planet Tax Free - Europe, Planet Tax Free – Middle East) and Planet Card Present Gateway (Planet Card Present Gateway).