PSM-566496 | Payment Processing Issue | UAE Region

Incident Report for weareplanet

Resolved

A fix has been implemented and services are operating as expected. Our teams will continue to monitor for stability.
Posted May 28, 2026 - 09:57 UTC

Identified

An issue has been identified and our teams are currently working on implementing a fix.
Posted May 28, 2026 - 09:07 UTC

Update

Our teams are continuing to investigate and work towards a resolution.
Posted May 28, 2026 - 08:28 UTC

Investigating

Some locations in the UAE region may be experiencing payment disruptions. Our teams are currently investigating.
Posted May 28, 2026 - 08:04 UTC
This incident affected: Planet Gateway - Card Present (Cluster 000067).