PSM-570115 | Planet Card-Present Gateway - The Americas

Incident Report for weareplanet

Resolved

The issue has been resolved and services are operating as expected. Monitoring will continue for stability.
Posted Jun 03, 2026 - 12:24 UTC

Investigating

A subset of customers may be experiencing transaction disruptions on the Planet Card‑Present Gateway. Impacted customers will have received a notification via the Status Page; if you have not received an email, your services are not affected.
Posted Jun 03, 2026 - 12:05 UTC
This incident affected: Planet Gateway - Card Present (Cluster 900070).