PSM-599263 – Potential Funding Delay

Incident Report for weareplanet

Resolved

Further to our previous update, we have sent direct communications to any customers who may be affected by a funding delay relating to this external incident.

These have been sent to the specified contact email address(es) registered on your account. Please refer to your email for the latest information relevant to your account.
Posted Jul 27, 2026 - 13:43 UTC

Update

Further to our previous update, settlement of the affected Visa transactions has not yet been received from Visa at the usual time and may be received later today. Whilst our processing remains complete, we are continuing to monitor closely and will provide a further update once the position is confirmed. As a result of this, merchant funding may still be delayed, and we will share an update as soon as possible.
Posted Jul 27, 2026 - 09:14 UTC

Monitoring

Following an external incident reported by Visa affecting Visa Clearing Exchange (VCX) processing, a number of Visa transactions required reprocessing over the weekend. While recovery activities have been completed on our side, final settlement of the affected transactions remains dependent on Visa.

Because settlement of the affected Visa transactions may be received later than usual, there is a possibility that merchant funding could be delayed. Our own processing has completed as expected; the potential delay relates to the aforementioned issue at Visa.

We will provide a further update tomorrow once settlement funding has been confirmed.
Posted Jul 26, 2026 - 21:10 UTC
This incident affected: Planet Acquiring Services / Host System (Planet Acquiring Host - Europe, Direct Funding).