PSM-621230 | Customer Communication Email Disruption | External to Planet

Incident Report for weareplanet

Resolved

Customer communication email delivery has returned to normal, and emails are now being delivered as expected. This issue was external to Planet, and has since been resolved. Our teams will continue to monitor for stability.
Posted Sep 04, 2026 - 19:57 UTC

Update

We are continuing to investigate this issue.
Posted Sep 04, 2026 - 15:07 UTC

Update

We are currently investigating an issue affecting the delivery of customer communication emails sent from Planet and Datatrans support services. Emails are being sent successfully; however, some recipients may experience delays in receiving them, including support correspondence and password reset emails. Our teams are actively investigating. For urgent matters, please call our support hotline.
Posted Sep 04, 2026 - 14:26 UTC

Investigating

We are currently investigating an issue affecting the delivery of customer communication emails sent from Planet and Datatrans support services. Emails are being sent successfully; however, some recipients may experience delays in receiving them, including support correspondence and password reset emails. Our teams are actively investigating.
Posted Sep 04, 2026 - 13:50 UTC