PSM-601409 | Payment Processing Issue

Incident Report for weareplanet

Resolved

This incident will now be closed on the Status Page. Our teams will continue to investigate the issue directly with the affected customers as part of ongoing troubleshooting. Any further updates will be provided through direct channels.
Posted Jul 29, 2026 - 17:13 UTC

Investigating

We are currently investigating a potential payment processing issue affecting Google Pay and Apple Pay transactions for a subset of customers. Our teams are actively investigating.
Posted Jul 29, 2026 - 16:39 UTC
This incident affected: Planet eCommerce Gateway - Digital / Web Payments (Payment Gateway Web2Pay WB) and Planet Gateway - Card Present (Cluster 000084).