Customer Services Disruption | Third-Party Provider Outage

Incident Report for weareplanet

Identified

Our service provider, Salesforce, has confirmed that one of their core system components is experiencing increased load, which is limiting its capacity to process requests. Salesforce has advised they are working on a fix to restore services.

Our customer services, including support correspondence and related communications, remain impacted. Our teams continue to monitor the situation and will provide a further update as soon as we receive more information from the provider.
Posted Sep 16, 2026 - 10:30 UTC

Investigating

One of our service providers, Salesforce, is currently experiencing a global outage. This is impacting our customer services, including support correspondence and related communications. Our teams are monitoring the situation and awaiting further updates from the provider.

https://status.salesforce.com/
Posted Sep 16, 2026 - 09:46 UTC