PSM-581783 | Non-Planet Acquired Transaction Disruptions | External to Planet

Incident Report for weareplanet

Resolved

Services have returned and are operating as expected. Our teams will continue to monitor the service.
Posted Jun 23, 2026 - 20:28 UTC

Update

Our teams are continuing to investigate the issue alongside our partners. A disruption has been acknowledged by a third‑party provider, which may be contributing to the current impact.
Posted Jun 23, 2026 - 20:12 UTC

Investigating

We are currently investigating a payment processing issue affecting certain non‑Planet‑acquired transactions.
Posted Jun 23, 2026 - 19:58 UTC
This incident affected: Third-Party Services (Third-Party Acquirers / Payment Processors) and Planet Gateway - Card Present (Cluster 000084).